www.sdlsuite.com Forum Index www.sdlsuite.com
Discussion of technical aspects of the SDL Component Suite
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Delphi 5

 
Post new topic   Reply to topic    www.sdlsuite.com Forum Index -> General Discussion
View previous topic :: View next topic  
Author Message
dlister



Joined: 07 Jun 2011
Posts: 1

PostPosted: Thu Jun 09, 2011 12:51 pm    Post subject: Delphi 5 Reply with quote

I use Delphi 5 for most of my pascal work,
and would like to keep this for now,
Can I use Mathpack with this version of Delphi,
in particular the FFT routines are of interest
Delphi 5 doesnt seem to be mentioned
Back to top
View user's profile Send private message
hlohning



Joined: 08 Sep 2006
Posts: 277
Location: Austria

PostPosted: Mon Jun 13, 2011 11:48 am    Post subject: Reply with quote

We are no longer supporting Delphi 5. The last version which is compatible to Delphi 5 is release 9.0
However, if you are interested to get the old Delphi 5 version, we offer a special agreement - buy any of the currently supported packages and you get the same package for Delphi 5 as a bonus at no extra costs (just mention in your order that you need Delphi 5 as well).

Regards,

Hans
_________________
Hans Lohninger
Software Development Lohninger
http://www.lohninger.com/
Back to top
View user's profile Send private message Visit poster's website
sdone



Joined: 27 Jan 2012
Posts: 1

PostPosted: Fri Jan 27, 2012 2:26 pm    Post subject: Moving from Delphi 5 to XE2 Reply with quote

Hi Hans,

I am moving my software product from D5 to XE2.
As there is no SDL Suite version that covers both these versions, what method would you recommend to migrate the SDL Suite related code with the minimum of problems?

I currently use D5 with SDL Suite Version 7.2.
Once I update my application to XE2, I will need to use SDL Suite Version 10.

I have bought the SDL v10 source.
Will I be able to compile this souce for Delphi 5, or does it no longer compile?
If it doesn't compile anymore, what is my best option?
Any problems or API changes I should look out for?

Best regards

Steve

P.S. I realise the problem is my own fault - I should have updated from Delphi 5 a long time ago!
Back to top
View user's profile Send private message
hlohning



Joined: 08 Sep 2006
Posts: 277
Location: Austria

PostPosted: Thu Feb 02, 2012 2:27 pm    Post subject: Reply with quote

Hi Steve,

I've to admit that I simply forgot which features are no longer supported when moving from D5 to higher compilers. So I suggest that you simply try to compile release 10 under D5 and drop me a mail if you need support.

Kind regards,

Hans
_________________
Hans Lohninger
Software Development Lohninger
http://www.lohninger.com/
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.sdlsuite.com Forum Index -> General Discussion All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group