www.sdlsuite.com Forum Index www.sdlsuite.com
Discussion of technical aspects of the SDL Component Suite
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TOnOffBut attaches only to parent

 
Post new topic   Reply to topic    www.sdlsuite.com Forum Index -> GuiPack
View previous topic :: View next topic  
Author Message
sterrel2



Joined: 16 Nov 2011
Posts: 4

PostPosted: Wed Nov 30, 2011 9:17 pm    Post subject: TOnOffBut attaches only to parent Reply with quote

C++ Builder 2010 + SDL setup_xxxxxx_0185650_guipack100_R7.exe

Hi, when I drop the TOnOffBut onto a form it seems that it will only attach to the parent form and not anything such as a panel on that form. This is a pity as it is quite a useful control.
Back to top
View user's profile Send private message
hlohning



Joined: 08 Sep 2006
Posts: 277
Location: Austria

PostPosted: Thu Dec 01, 2011 3:48 pm    Post subject: Reply with quote

Hm, I just tested this.... It seems that this is only an issue with RadStudio XE2. I've to do further investigations to get a clearer picture.

Anyway, there seems to be a simple workaround: put the component from the palette to the form. Then select it and cut it to the clipboard. Next select the panel and paste the clipboard contents to the panel. This way it attaches to the panel (weird, isn't it?)

Regards,

Hans
_________________
Hans Lohninger
Software Development Lohninger
http://www.lohninger.com/
Back to top
View user's profile Send private message Visit poster's website
sterrel2



Joined: 16 Nov 2011
Posts: 4

PostPosted: Thu Dec 01, 2011 4:10 pm    Post subject: Reply with quote

Hi, thanks for the reply

On my Builder 2010 even the cut and paste (Ctrl X, select a panel, Ctrl V) does not work, it still drops back to the parent underneath the panel.

Steve
Back to top
View user's profile Send private message
hlohning



Joined: 08 Sep 2006
Posts: 277
Location: Austria

PostPosted: Thu Dec 01, 2011 7:45 pm    Post subject: Reply with quote

Hi Steve,

I just started up my C++Builder 2010 copy (in fact I've RadStudio 7 installed). When I put the OnOffBut component on a panel it attaches to the form. But I can cut and paste it to panel - which works as described before, the pasted component attaches to the panel.

So, I'll go into it during the next hours and report my findings....

Kind regards,

Hans
_________________
Hans Lohninger
Software Development Lohninger
http://www.lohninger.com/
Back to top
View user's profile Send private message Visit poster's website
sterrel2



Joined: 16 Nov 2011
Posts: 4

PostPosted: Thu Dec 01, 2011 8:37 pm    Post subject: Reply with quote

Interesting results

I created a small VCL form example, dropped a panel onto it then was able to drop a OnOffBut onto the panel??

Strange? How did i do that??

So some experiments...

What I am finding is that if the panel is selected (blue dots around it) then the OnOff selected from the Tool Palette then the panel clicked again to drop the button it attaches to the base form. If the panel is then selected again and Ctrl V the(second) button is attached to the panel.

This is I think what you are seeing.

So the problem appears to be the sequence - select the container (i.e. panel) select the button on the palette click back on the container and the button connects to the form not the container.

That sequence with other components like TMeter works in that they attach to the previously selected container.

Hope that helps

Steve
Back to top
View user's profile Send private message
hlohning



Joined: 08 Sep 2006
Posts: 277
Location: Austria

PostPosted: Thu Dec 01, 2011 9:01 pm    Post subject: Reply with quote

Hi Steve,

thanks for your feedback! This finally pointed me in the right direction. So the bug is fixed now. I'll send you a mail with the download instructions for the beta having this bug fixed.

Regards,

Hans
_________________
Hans Lohninger
Software Development Lohninger
http://www.lohninger.com/
Back to top
View user's profile Send private message Visit poster's website
sterrel2



Joined: 16 Nov 2011
Posts: 4

PostPosted: Fri Dec 02, 2011 9:34 am    Post subject: Reply with quote

Works fine now, thanks

Steve
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.sdlsuite.com Forum Index -> GuiPack All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group